Kaltura technical team actively investigating

Incident Report for Kaltura Australia Regional Cloud

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:03 UTC

Investigating

Kaltura's technical team is actively investigating an issue which has affected services.

As information arrives, more updates will follow on this page.

Thank you for your patience,
The Kaltura team.
Posted Dec 05, 2025 - 09:08 UTC
This incident affected: Kaltura API and Kaltura MediaSpace.